Disruption of online transactions via Saferpay/Worldline

Incident Report for TrekkSoft

Resolved

Saferpay has confirmed that the incident is resolved. At the current time we do not have further information about the cause of the incident.

Start of disruption: Wednesday, November 12, 2025, 19:07 CET
End of disruption: Wednesday, November 12, 2025, 21:40 CET

We apologize for any inconvenience this has caused you.
Posted Nov 12, 2025 - 22:39 CET

Update

Processing has been stable for the last 20 minutes. We'll continue monitoring the situation.
Posted Nov 12, 2025 - 22:16 CET

Monitoring

We've seen some improvements in payments handling, but are still observing issues related to SCA/3DS redirects back to Saferpay. Transactions without additional user authentication seem to be processed again.
Posted Nov 12, 2025 - 21:24 CET

Identified

We've received confirmation from Worldline that the following services are currently interrupted:

- Processing of online transactions from Saferpay by American Express CH
- Processing of online transactions from Saferpay by American Express DE
- Processing of online transactions from Saferpay by Giropay
- Processing of online transactions from Saferpay by Intercard
- Processing of online transactions from Saferpay by Klarna
- Processing of online transactions from Saferpay by Worldline CH
- Processing of online transactions from Saferpay by Worldline EU
- Processing of online transactions from Saferpay by American Express SafeKey
- Processing of online transactions from Saferpay by Saferpay Backoffice
- Processing of online transactions from Saferpay by Diners ProtectBuy
- Processing of online transactions from Saferpay via Mastercard ID Check
- Processing of online transactions from Saferpay via VISA Secure
- Processing of TWINT online transactions from Saferpay (SATA)
Posted Nov 12, 2025 - 20:10 CET

Investigating

We are investigating an issue causing payment failures. We've traced the problem to our external payment gateway and are monitoring their investigation. We will update you as we learn more.
Posted Nov 12, 2025 - 20:05 CET
This incident affected: Payyo - Payment Gateway.